#187 ✓resolved
Jamie Macey

Current integrity gem Does Not Work, we need a new release that does.

Reported by Jamie Macey | July 23rd, 2009 @ 05:47 PM

The current integrity gem requires sinatra 0.9.1.1, which needs rack < 1.0. Thin needs rack >= 1.0, which is no good. (see #184, #175 as well)

I attempted to manually build my own gem to install with, and after modifying the bob and bobette dependencies to be integrity- (they're not available plain on github at all, yet) I'm getting another dependency conflict in that data_objects wants addressable 2.0. but bob loads 2.1.0.

Having already spent over an hour on this, I'm now giving up. It might be an idea to add to integrity's integrity install a builder that sets up empty rip env, installs integrity, and ensures that it can launch - a gem that I can't use is worse than no gem at all.

Comments and changes to this ticket

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Automated continuous integration server that doesn't suck.

Shared Ticket Bins

People watching this ticket

Tags

Pages